Login Main site Create account

26.07.2007 16:29

Matrox Parhelia Driver 1.4.5.1 for Linux is out


Unofficial Matrox Parhelia drivers This is the first unofficial mtx driver release based upon the new official 1.4.5 core. It contains only minor modifications (see ChangeLog below) but was the first step to sync it up with the 1.4.4 unofficial releases.

Downloads:
Please consider donating if you use this driver

ChangeLog:
1.4.5.1:
  * First unofficial driver release based upon the 1.4.5 core
  * Reintroduced this ChangeLog file and moved it to the top of the
    extracted driver archive
  * Reintroduced the file "make.sh" in the driver root
  * mtx_agp.c:
    - Removed the 'strucure' typo again
    - Removed the 'cleanup:' jumpmarks as they are only used once
  * mtx_os.c:
    - Reintroduced the 'memset before check' bugfix
  * mtx_strintf.c:
    - Reintroduced the 'memset before check' bugfix
  * mtx_drv.c:
    - Reintroduced pci_register_driver/pci_module_init compatibility update
    - Added unofficial version output
  * mtxversion.h:
    - Added unofficial version
  * install.sh:
    - installs the v4l module automatically again

1.4.5:
  * Official Matrox release.
    I don't know what Matrox has changed in 1.4.5, but I recognized a
    few things that don't work anymore or have changed in behaviour:

    - They added a file called x86_32 resp. x86_64 with no content to
      specify the architecture of the driver installer package
    - They added a file called version.txt containing the version of the
      driver
    - They updated install.sh (shrinked it down from 3089 to 803 lines) so
      please have a look yourself about what has changed. Currently, I just
      recognized two things:
        o The v4l driver doesn't get installed automatically
        o The installer automagically installs the oldest mtx_drv.so if
          it has troubles in detecting your X version. This usually applies
          to all Debian based distributions which introduced the new Xorg
          modular versioning scheme (e.g. 1.3.0 instead of 7.3.0).
    - They made warnings out of most AGP related error messages instead of
      looking at the cause (sigh)
    - They changed the wording of some error- and informational messages
      in the parhelia library ("Cannot stop Matrox xform" vs. "Cannot stop
      features")
    - They managed to break switching between X and a running framebuffer
      enabled console (with 1.4.4 that used to work flawlessly, now with 1.4.5
      you need to stop the X server before you can work at your text console
      again)
    - In some places they dropped backwards compatibility to older kernel
      versions as well as removed forwards compatibility to 2.6.22 f.ex.

Links:
Comments added earlier to http://tuxx-home.at/archives/2007/07/26/T16_29_26/index.html:
Guest on 2007-08-08 03:36:00 wrote:
Thanks for your continued work on these drivers - they are sincerely appreciated!

Your comment (HTML tags will be stripped !!):

To verify You are not a bot, type down text from this image.

Your try: